Download Reference Manual
The Developer's Library for D
About Wiki Forums Source Search Contact

Ticket #921 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Linux installer including DMD doesn't work

Reported by: Deewiant Assigned to: larsivi
Priority: major Milestone: 0.99.5
Component: Packaging Version: 0.99.4 Frank
Keywords: Cc:

Description

I tried to install Tango+DMD using the http://downloads.dsource.org/projects/tango/0.99.4/tango-0.99.4-bin-dmd.1.024-posix-withDMD.sh installer.

Running it as ./(long name.sh) --prefix ~ resulted in it creating an empty bin directory in ~ and the dmd, dumpobj, and obj2asm binaries directly in ~.

Thereafter it gave the error Failed to install Tango core upon trying, and failing, to run ./install-dmd.sh.

Change History

02/18/08 05:53:38 changed by Jim Panic

Try to run it twice. It should work the second time. It's kind of a mystery to me why this happens..

02/18/08 08:00:33 changed by Deewiant

Interesting. It did work now that I tried it (although I do think I tried that when I filed this ticket...).

Still, the 3 binaries mentioned are left directly in the PREFIX directory and not in PREFIX/bin.

And, of course, the whole thing isn't exactly expected behaviour.

02/19/08 00:13:17 changed by Jim Panic

  • status changed from new to closed.
  • resolution set to fixed.

These bugs seem to be fixed now. What puzzles me is the fact that ~ automatically gets expanded to an absolute path by bash?

I'll tag this ticket as fixed for revision 3225. If there are any further problems, please reopen and comment here.