Download Reference Manual
The Developer's Library for D
About Wiki Forums Source Search Contact

Ticket #912 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Warning messages from recent math.IEEE changes

Reported by: kris Assigned to: Don Clugston
Priority: normal Milestone: 0.99.8
Component: Core Functionality Version: 0.99.4 Frank
Keywords: Cc:

Description

some warnings slipped in here recently (compile with -w)

Change History

02/19/08 07:04:47 changed by larsivi

#928 marked as duplicate - see it for messages

02/19/08 08:18:30 changed by Don Clugston

This really sucks. DMD generates a warning whenever a bitwise logical operation is performed on anything other than an int. These warnings NEVER, under ANY circumstances, indicate a bug. Really, -w is so horribly broken, I don't know why anyone uses it. It's almost inevitable that it reduces code quality.

short a; short b; short c = a|b; // generates a warning.

This is bugzilla 1257. I've introduced a horrible workaround to stop this warning (it is most definitely not a bugfix).

02/19/08 19:11:47 changed by larsivi

  • status changed from new to assigned.
  • owner changed from Don Clugston to larsivi.
  • milestone changed from 0.99.5 to External Bugs.

[3228] is a workaround for these warnings.

02/25/09 08:35:34 changed by larsivi

  • owner changed from larsivi to Don Clugston.
  • status changed from assigned to new.

Were the workarounds detailed here reverted? If they were (or are), and DMD doesn't warn anymore, then we can close this ticket.

02/25/09 08:37:23 changed by Don Clugston

  • status changed from new to closed.
  • resolution set to fixed.

Yes, they're reverted. The DMD bug was fixed. Yay!

02/25/09 09:56:04 changed by larsivi

  • milestone changed from External Bugs to 0.99.8.

Yay!