Download Reference Manual
The Developer's Library for D
About Wiki Forums Source Search Contact

Ticket #811 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

scope interface instances in unit tests causes crash

Reported by: jhouse Assigned to: larsivi
Priority: major Milestone: 0.99.5
Component: Core Functionality Version: 0.99.3 Triller
Keywords: Cc:

Description

This was submitted as issue 1719 with D, but appears to be tango-specific. I just tested it with the latest windows download from the tango site (dmd 1.023 w/ Tango 0.99.3)

http://d.puremagic.com/issues/show_bug.cgi?id=1719

Attachments

test.d (313 bytes) - added by jhouse on 12/10/07 15:34:48.
File demonstrating problem

Change History

12/10/07 15:34:48 changed by jhouse

  • attachment test.d added.

File demonstrating problem

12/10/07 20:43:20 changed by sean

  • status changed from new to assigned.

The problem is not Tango-specific, but I will leave the ticket open anyway.

01/14/08 23:54:08 changed by sean

  • status changed from assigned to closed.
  • resolution set to invalid.

Since this isn't a bug in Tango, I'm marking this as invalid.

01/22/08 23:11:36 changed by larsivi

  • status changed from closed to reopened.
  • resolution deleted.
  • milestone set to External Bugs.

Reopening and listing in ToolchainIssues.

02/13/08 09:46:05 changed by larsivi

#898 is a duplicate of this.

02/13/08 09:46:45 changed by larsivi

Note that in DMD 1.026, this breaks Tango and is slated for a fix in DMD 1.027.

02/13/08 17:38:00 changed by kris

  • status changed from reopened to new.
  • owner changed from sean to DRK.
  • milestone changed from External Bugs to 0.99.5.

We should fix it in the interim anyway

02/16/08 08:17:54 changed by larsivi

  • owner changed from DRK to larsivi.
  • milestone changed from 0.99.5 to External Bugs.

03/21/08 11:43:51 changed by larsivi

  • status changed from new to closed.
  • resolution set to fixed.
  • milestone changed from External Bugs to 0.99.5.

This was fixed in DMD 1.027