Download Reference Manual
The Developer's Library for D
About Wiki Forums Source Search Contact

Ticket #272 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Oops... for Forums.

Reported by: keinfarbton Assigned to: brad
Priority: major Milestone: 0.96 Beta 2
Component: Web frontend Version:
Keywords: Cc: brad

Description

I am logged in as 'keinfarbton'. Click on Menu 'Forums' and get:

Oops…
Trac detected an internal error:

If you think this really should work and you can reproduce it, you should consider reporting this problem to the Trac team.

Go to http://trac.edgewall.org/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the Python traceback found below.

TracGuide — The Trac User and Administration Guide
Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 451, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 265, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/tracforums/web_ui.py", line 321, in process_request
  File "build/bdist.linux-i686/egg/tracforums/models/main.py", line 35, in getViewTemplate
  File "build/bdist.linux-i686/egg/tracforums/models/project.py", line 21, in getSimpleList
  File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: invalid input syntax for integer: "tango"

Change History

02/11/07 13:29:18 changed by larsivi

  • milestone set to 0.96 Beta 2.

Site reverted to r51 of the forums for now.

02/11/07 18:49:42 changed by keinfarbton

  • status changed from new to closed.
  • resolution set to worksforme.

today it works.

02/11/07 18:57:12 changed by larsivi

  • status changed from closed to reopened.
  • resolution deleted.

because it was reverted .. the error isn't fixed.

02/12/07 02:14:38 changed by pragma

I have no clue why this happened.

My current environment is divergent from r53, so this may take some time to fix.

03/12/07 14:08:40 changed by pragma

I am still unable to reproduce this problem so I have either refactored it away (uinintentionally) or it is related to the schema/data present here on dsource.

I will put in some more testing effort on tracforums rev 54 before attempting to commit it here.

03/13/07 14:37:32 changed by pragma

  • status changed from reopened to closed.
  • resolution set to worksforme.

This should be taken care of in the most recent version. Will reopen if problem persists.

03/14/07 01:03:45 changed by brad

  • cc set to brad.
  • status changed from closed to reopened.
  • resolution deleted.

I can duplicate this when I'm logged out, and visit the forums.

03/14/07 03:16:26 changed by pragma

  • owner changed from pragma to brad.
  • status changed from reopened to new.

Brad, looks like this one is in your court.

It looks like the project view you have is mapped incorrectly. I think the 'id' column should map to the 'code' column of the original projects table. The values in the 'id' colum are expected to be of type varchar(32), unique per project, and correspond to the projectid as specified in the trac.ini file for the project.

(follow-up: ↓ 10 ) 03/14/07 15:20:33 changed by brad

  • status changed from new to closed.
  • resolution set to fixed.

ok, I think this one is put to bed. I changed the view to use project_code, project_name, and active. Thanks for finding the cause. Why does this not rear its head when logged in?

(in reply to: ↑ 9 ; follow-up: ↓ 11 ) 03/14/07 16:44:30 changed by pragma

Replying to brad:

ok, I think this one is put to bed. I changed the view to use project_code, project_name, and active. Thanks for finding the cause. Why does this not rear its head when logged in?

http://www.dsource.org/projects/tracforums/browser/trunk/tracforums/models/main.py#L35 http://www.dsource.org/projects/tracforums/browser/trunk/tracforums/models/project.py#L11

As it turns out, you and I are simply too privileged to notice. :(

The query aggregation only restricts the possible set of projects to display for the "move selection panel", iif the user is not an admin. The restriction (where clause) is what was failing.

(in reply to: ↑ 10 ; follow-up: ↓ 12 ) 03/15/07 01:02:42 changed by brad

Replying to pragma:

As it turns out, you and I are simply too privileged to notice. :(

screw the peons

(in reply to: ↑ 11 ) 03/15/07 01:11:27 changed by pragma

Replying to brad:

screw the peons

Pragma clicks on Peon

Peon: But I don't want to work.

Pragma clicks again on Peon, then on Gold Mine

Peon: Yesh, melord.