Download Reference Manual
The Developer's Library for D
About Wiki Forums Source Search Contact

Tango installation

Moderators: larsivi kris

Posted: 07/08/08 20:08:23

Hello, I've tried many variation of installation, but found no normal way to do it :( All i want is a DMD (1.031), Tango (0.99.6), and maybe DSSS (need to easily install DBI, mango, fast4d and compile projects, or any other choice?).. Is there any normal way, tried a few tutorials but it didn't make any positive results :(

My system: Fedora Core 6/Gentoo..

Thanks,anymore...

Author Message

Posted: 07/08/08 23:08:32

Hard to understand what is the real problem here; installing D libraries isn't particularly different from C/C++ libraries. I assume you are able to install DMD and Tango properly, at which point all other libraries typically follow the same pattern.

Place the import files in a folder, no problem in having the various project roots in the same place, could even be where Tango is installed. If you also want binary library files, you need to see if the D library supports building those (not all do), or if they have DSSS config file. If they have, they are easily built and installed. This would however mean that you would need to use DSSS for your own project too.

All-in-all, using several libraries will always be somewhat of a manual process if DSSS doesn't support it, with installation, building and configuration. I don't think you are missing anything, this is just the way it is.

Posted: 08/31/08 16:24:58

I also find it quite hard to get a working D dev inviorment. I'm developing a game and want to port what I started in c++ to D. I think I need gdc or dmd, tango and dsss so I downloaded http://downloads.dsource.org/projects/tango/0.99.7/tango-0.99.7-gdcr243-forDSSS-gdc-i686-pc-linux-gnu-withDSSS-withGDC.sh which seem to be a bundel all I need and installed it. The install worked fine and I could build a hello world example with dsss. The problem is I cannot install derelictsdl

fabe@fabetop:~/workspace/test$ sudo dsss net install derelictsdl
[sudo] password for fabe: 
Synchronizing...
+ curl -s -S -k http://svn.dsource.org/projects/dsss/sources/source.list -o /usr/share/dsss/sources/source.list -z /usr/share/dsss/sources/source.list
+ curl -s -S -k http://svn.dsource.org/projects/dsss/sources/pkgs.list -o /usr/share/dsss/sources/pkgs.list -z /usr/share/dsss/sources/pkgs.list
+ curl -s -S -k http://svn.dsource.org/projects/dsss/sources/mirrors.list -o /usr/share/dsss/sources/mirrors.list -z /usr/share/dsss/sources/mirrors.list

Working in /tmp/DSSS_derelictsdl
+ svn export http://svn.dsource.org/projects/derelict/trunk/DerelictSDL
sh: svn: not found
+ curl -k http://dsss.brainsware.org/mirror/derelictsdl.tar.gz -o derelictsdl.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 14510  100 14510    0     0  64899      0 --:--:-- --:--:-- --:--:--  115k
+ gunzip -c derelictsdl.tar.gz | tar -xf -


Installing derelictutil

Working in /tmp/DSSS_derelictutil
+ svn export http://svn.dsource.org/projects/derelict/trunk/DerelictUtil
sh: svn: not found
+ curl -k http://dsss.brainsware.org/mirror/derelictutil.tar.gz -o derelictutil.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  5006  100  5006    0     0  35319      0 --:--:-- --:--:-- --:--:--  106k
+ gunzip -c derelictutil.tar.gz | tar -xf -
Creating imports for DerelictUtil

derelict => DerelictUtil
+ /usr/bin/rebuild -Idsss_imports/ -I. -S./ -I/usr/include/d -S/usr/lib/  -I/usr/include/d -S/usr/lib -I/home/fabe/d/include/d -S/home/fabe/d/lib  -oqdsss_objs/G  -explicit -lib derelict/util/wintypes.d derelict/util/wrapper.d derelict/util/exception.d derelict/util/loader.d -oflibDerelictUtil.a
derelict/util/wrapper.d:69: Error: undefined identifier fromUtf8z
derelict/util/wrapper.d:69: Error: function expected before (), not fromUtf8z of type int
derelict/util/wrapper.d:69: Error: cannot implicitly convert expression (fromUtf8z(cstr)) of type int to char[]
Command /usr/bin/rebuild returned with code 256, aborting.
Error: Command failed, aborting.

Ive tried several times to install dsss, tango and their always seems to be something that dosent work :/

Posted: 08/31/08 17:59:11

Hi fabe, sorry to hear that you have problems. In this specific case, it is easily identifiable and is not a Tango problem. The errors shos that either dsss installs a too old version of derelictsdl, or that derelictsdl is out of date when compared to Tango. I suggest taking up the problem in the derelict forum first, dsss second.

Posted: 08/31/08 18:50:30

Thx I downloaded the latest derelict revision from their svn and it built fine. It seems the dsss guys may not have been updateing their system as other libs wont install with dsss aswell.