Note: This website is archived. For up-to-date information about D projects and development, please visit

Installing and running Trac on Mac OSX

Fink ( can be used to install most of Trac's dependencies:

 $ apt-get install sqlite
 $ apt-get install svn-client svn-swig-py23

If you need to use a secure protocol with subversion, you need to install the -ssl variants:

 $ apt-get install svn-client-ssl svn-ssl-swig-py23

The last two dependencies (pysqlite and clearsilver) can't be installed using fink, you have to download and install them manually.


Download latest version from Compile it with Python support and install it in the fink prefix.

 $ ./configure --prefix=/sw/ --with-python=/sw/bin/python2.3
 $ make install

You might have to modify some some hard coded /usr/local/bin/python path to /sw/bin/python2.3 in some file when running make install.


The file in the pysqlite distribution doesn't recognize the darwin platform so you'll have to add the following lines to (it should be quite obvious where):

elif sys.platform == "darwin":
    include_dirs = ['/sw/include/']
    library_dirs = ['/sw/lib/']
    libraries = [sqlite]
    runtime_library_dirs = []
    extra_objects = []

After that modification the installation should simply be:

 $ /sw/bin/python2.3 ./ install

Installing Trac itself

You should now be all set to install Trac using the TracInstall instructions. Make sure to use /sw/bin/python2.3 when running the script.

I had some problems getting apples personal web-server (apache 1.3) to run trac.cgi with the correct python interpreter (/sw/bin/python2.3) so I placed this dummy trac.cgi in /Library/WebServer/CGI-Executables/:

#! /bin/sh
/sw/bin/python2.3 /somewhere/cgi-bin/trac.cgi

Keep in mind that these instructions were written from the top of my mind and might be incomplete and contain some errors. If you find any errors please correct them by editing this page and/or contacting me -- JonasBorgstrom

Alternative install method: pkgsrc

As an alternative to fink and compiling by hand, you can install from pkgsrc ( Yes, pkgsrc runs on Mac OS X just as well as it runs on NetBSD or Linux.

See TracOnNetBsd for more information.